Trouble processing with Khipu [MLC]
Incident Report for MercadoPago
Resolved
This incident has been resolved.
Posted 3 months ago. May 21, 2019 - 10:42 GMT-03:00
Identified
We are currently experiencing trouble processing payments with Khipu.
Posted 3 months ago. May 21, 2019 - 10:38 GMT-03:00