URUGUAY - Abitab Contingencies
Incident Report for Mercado Pago
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 10:56 GMT-03:00
Identified
The following payment methods are experiencing trouble in payment approval: Abitab. Approval's attempts are being received correctly and will be processed in the next few hours.
Posted Nov 14, 2022 - 10:40 GMT-03:00
This incident affected: Uruguay (Payment Processing).