COLOMBIA - Contingencies PSE
Incident Report for Mercado Pago
Resolved
This incident has been resolved.
Posted Mar 07, 2023 - 15:34 GMT-03:00
Identified
We are experiencing issues affecting the payment processing for payment method PSE (Colombia).
Posted Mar 07, 2023 - 15:12 GMT-03:00
This incident affected: Colombia (Payment Processing).