COLOMBIA - Contingencies PSE
Incident Report for Mercado Pago
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 05:57 GMT-03:00
Identified
We are experiencing issues affecting the payment processing for payment method PSE (Colombia).
Posted Sep 09, 2022 - 05:43 GMT-03:00
This incident affected: Colombia (Payment Processing).