ARGENTINA - Contingencies Mercado Pago Checkout
Incident Report for MercadoPago
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 04:13 GMT-03:00
Identified
We’ve noticed some issues with Mercado Pago Checkout. We’re currently investigating the root cause and will update as soon as possible.
Posted Mar 13, 2020 - 04:08 GMT-03:00