COLOMBIA - PSE Errors in payment processing
Incident Report for Mercado Pago
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 19:25 GMT-03:00
Investigating
We are experiencing issues affecting the payment processing for payment method PSE (Colombia)
Posted Jun 17, 2022 - 17:51 GMT-03:00
This incident affected: Colombia (Payment Processing).