ARGENTINA - Pago Fácil Contingencies
Incident Report for Mercado Pago
Resolved
This incident has been resolved.
Posted May 14, 2020 - 14:15 GMT-03:00
Identified
The following payment methods are experiencing trouble in payment approval: Pago Fácil. Approval's attempts are being received correctly and will be processed in the next few hours.
Posted May 14, 2020 - 14:12 GMT-03:00
This incident affected: Argentina (Payment Processing).