CHILE - Contingencies Khipu
Incident Report for Mercado Pago
Resolved
This incident has been resolved.
Posted Jul 12, 2019 - 14:26 GMT-03:00
Identified
We have momentarily turned off Khipu payment method due to high response times. It'll soon be available again.
Posted Jul 12, 2019 - 14:10 GMT-03:00